Menjalankan Oracle dengan XAMPP di Windows XP

Dalam membuat sebuah aplikasi untuk salah satu usaha saya, saya dihadapkan dengan Windows XP yang notabennya cukup ketinggalan zaman karena salah satu aplikasinya hanya dapat jalan di Windows XP. Aplikasi yang saya buat adalah menggunakan PHP dimana saya ingin mengcopy data aplikasi yang databasenya menggunakan oracle express edition di komputer itu ke server saya di data center. Dengan demikian solusinya saya menginstall XAMPP pada komputer tersebut lalu membuat aplikasi sederhana untuk mengirimkan datanya ke server saya.

Namun kendala terjadi saat mengaktifkan oci8 pada XAMPP di Windows XP. Muncul notifikasi dengan tulisan “PHP Startup: Unable to load dynamic library php_oci8.dll could not be found”. Dan saya periksa kembali koneksi oci8 pada phpinfo() tidak keluar.

Selengkapnya ...

Contoh Menyingkat PHP If / Else

Dalam coding seringkali kita menggunaan metoda if / else dalam mengimplementasikan suatu logika pemikiran. Metoda if / else standar adalah sebagai berikut:

if (kondisi) {
kode yang dijalankan jika kondisi benar;
} else {
kode yang dijalankan jika kondisi salah;
}

Setelah mempelajari lagi lebih dalam mengenai metoda if / else maka saya menemukan banyak cara dalam mempersingkat penulisan metode tersebut yakni:

(kondisi) ? kode yang dijalankan jika kondisi benar : kode yang dijalankan jika kondisi salah;

Selengkapnya ...

Install Oracle Forms / Reports 6i di Windows 10

Saya mencoba untuk melakukan instalasi Oracle Forms / Reports 6i pada Windows 10 64-bit. Saat instalasi terdapat peringatan seperti dibawah ini.

“A PERMISSION DENIED ERROR while trying to copy E:\oracle 6i\ path to “c:\windows\system32\MSVCRT40.DLL”. Would you like to retry the operation, ignore the error, or allow the error to be processed by the installer”.

Hal ini membuat saya bertanya-tanya kenapa saat melakukan instalasi di Windows 8 lancar-lancar saja, namun di Windows 10 terdapat masalah. Namun setelah bertemu om google, diberikanlah saya petunjuk yaitu dengan menghapus beberapa baris dalam file instalasi.

Selengkapnya ...

Install OCI8 untuk PHP5 di cPanel

Kantor saya menggunakan cPanel sebagai web servernya agar mudah dikelola. Suatu hari ada keputusan dari manajemen untuk melakukan perubahan aplikasi dari kantor pusat yang menggunakan database Oracle. Dan kami dituntut untuk melakukan pengembangan aplikasi tersebut. Diputuskan juga pengembangan aplikasi tersebut menggunakan PHP untuk kemudahan akses yang didesign secara responsive.

Pada saat saya melakukan koneksi aplikasi PHP dengan database oracle, terjadi error dengan keterangan:

Fatal error: Call to undefined function oci_connect()

Sayapun melakukan instalasi module oci8 pada PHP Pecl di cPanel. Namun hal tersebut gagal karena PHP yang saya gunakan ada PHP5, sedangkan pada module PHP Pecl di cPanel sudah harus menggunakan PHP7. Error yang tampil adalah:

pecl/oci8 requires PHP (version >= 7.0.0), installed version is 5.5.37
No valid packages found
install failed

Selengkapnya ...